+1
Started

Internet explorer 8 bug

Matthew O'Riordan 6 years ago in Widgets • updated by Sergey Stukov (co-founder) 6 years ago 1
Hi there


One of my users recently pointed out that on IE8 (I know, an old browser, but we still support it), they get a script error on every page.  The script error is being generated from the widget javascript file served from you, so in order to replicate the issue easily I created a simple HTML file with only your Javascript include, opened it in IE8, and I have the same issue.


There error message I receive is "Object required, line 1, char 5834".  Attached is a screen shot and also pasted below is the source for the most basic HTML file following the instructions exactly for how to embed your code.  Please can you look into this as I would like to stop this error in our production environment.


Matt




<html>

<script type='text/javascript'>


var _ues = {

host:'easybacklog.userecho.com',

forum:'4890',

lang:'en',

tab_corner_radius:10,

tab_font_size:20,

tab_image_hash:'RmVlZGJhY2s%3D',

tab_alignment:'left',

tab_text_color:'#FFFFFF',

tab_bg_color:'#FF0000',

tab_hover_color:'#F45C5c'

};


(function() {

  var _ue = document.createElement('script'); _ue.type = 'text/javascript'; _ue.async = true;

  _ue.src = ('https:' == document.location.protocol ? 'https://s3.amazonaws.com/' : 'http://') + 'cdn.userecho.com/js/widget-1.4.gz.js';

  var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(_ue, s);

})();


</script>

<body>

Simple empty page

</body>

</html> 

Answer

Answer
Started
Will fix it ASAP
Answer
Started
Will fix it ASAP

any update on this? IE8 and IE9 do not work for me. (serveituphealthy.com)