0
Under review

Topic loads really slow

Alexander Blach 6 years ago in Usability & Interface • updated by Sergey Stukov (co-founder) 6 years ago 4
I noticed that the topic at http://feedback.textasticapp.com/topic/7628-support-for-version-control-systems-svn-git-etc/ loads really slow. Safari (Mac) almost stops responding when loading it.

I already tried removing the Facebook and Twitter widgets, but that didn't help.

I had a look at the network traffic, and loading one request from "io.userlook.com" takes nearly 17 seconds. It looks like this is causing the delay:

Answer

Answer
Under review
We did check, io.userlook takes 155ms from our side at this moment.
But we try to pay more attention for performance.
Our target that any server response fit to the 1 second.
Answer
Under review
We did check, io.userlook takes 155ms from our side at this moment.
But we try to pay more attention for performance.
Our target that any server response fit to the 1 second.
It's really unusable over here in Germany. It takes "forever" before you can scroll down the website.
Now, the io.userlook.com echo does load fast. But it still takes a long time before I can scroll down the page. There must be a different reason why this happens.
We will perform speed checks and optimization today. Will report about progress here.
I had a closer look at the network traffic. I think it could be a problem with loading the avatars from gravatar. There are many users who commented on the topic I linked to, and it takes some time to get a http 304/not modified response from www.gravatar.com/avatar. 

Maybe load time could be improved by loading some images or scripts asynchronously.