0
Fixed

Merge doesn't work on the first try

Alexander Blach 5 years ago in Usability & Interface • updated by Vladimir Mullagaliyev (co-founder) 5 years ago 10
The last two times I tried to merge a topic with an existing one, it didn't work on the first try. After the first "merge", the topic still appeared as a separate topic instead of as a duplicate.

I had to do the merge a second time before it appeared as a duplicate in the existing topic.

Is this a known problem?

Answer

Answer
Fixed
Hello Alexander. Thank you for screencast. It really help to us. 
It seems like we have found problem and you will have no the same issue again.
Under review
Hello Alexander,
We had the similar bag report from one of our clients but we can't reproduce it.
It would be great if next time when you will have it you do screencast or send to us information with topics that you can't merge. We will try to merge it for you and try to locate problem.
I just wanted to merge this topic: http://feedback.textasticapp.com/topic/443461-spel... with this one: http://feedback.textasticapp.com/topic/134687-merg...

It didn't work. When I would now try to merge it a second time, I'm pretty sure it would work.

So far it happened with every new topic that I wanted to merge with an existing topic...
Hello Alexander,
We have tried to merge it and have no any problem. 
It doesn't matter will you merge it first time or second, because we have no any flags.

Did you see that now we have two types of merging and they works different. After second type the window stay opened.

Which type of merging do you use and wat happened with the window after confirmation? Which topic do you see after close the window?

P.S.: We have unmerge topics for your test.
I just merged the topic and there was no problem now. I'll create a video before I try the next time!
I just merged three or four other topics successfully and I didn't do anything differently. Maybe it happens the next time a user adds a new topic...
I had the merge problem again. This time I could do a screencast. You can see it here: https://www.dropbox.com/s/joh4sgfifk6o7br/Userecho...

I tried to merge this new topic: http://feedback.textasticapp.com/topic/444850-ope... with this old one: http://feedback.textasticapp.com/topic/27218-edit-...

If I would try to merge the topics for a second time now, I'm sure it would work! It's only the first time that doesn't work.
Answer
Fixed
Hello Alexander. Thank you for screencast. It really help to us. 
It seems like we have found problem and you will have no the same issue again.
Thanks! I'm curious: can you tell me what the problem was?
+1
It was some specific of our code. One of save method rewrite the other one. And it happened when the topic was with "needs review" status only. The status was reset after first try and all works fine after that.