Eugene Pankov
Example: http://support.ajenti.org/topic/349870-ajenti-behi...
URLs in code paragraphs are hotlinked, but when clicking "edit article", <a href.... appears instead in the editor. After saving, the link is double-URLized again, resulting in a piece of broken HTML with two hyperlinks.
Vladimir Mullagaliyev
Answer Fixed
We have disabled auto marking for links in content with PRE tags.
Eugene Pankov
Quote from Vladimir Mullagaliyev
We have disabled auto marking for links in content with PRE tags.
Links are now not marked when viewing page, but if you try to edit it, links are marked again after first edit (I mean they get marked in the rich text editor on client side).
Eugene Pankov
Quote from Vladimir Mullagaliyev
We have disabled auto marking for links in content with PRE tags.
Also, links get URLized when pressing Enter. Example: http://support.ajenti.org/topic/349870-ajenti-behind-nginx/
Vladimir Mullagaliyev
Quote from Eugene Pankov
Also, links get URLized when pressing Enter. Example: http://support.ajenti.org/topic/349870-ajenti-behind-nginx/
We have enabled auto URLization for links in the redactor. It helps URLize links, but redactor has some bug. It should skip URLs in the <PRE></PRE> tag.

Hope it will be fixed in the next versions of redactor.
 Sign in to leave a comment