Possibility to translate the texts for inserted links

Ryann 4 years ago in Multilanguage • updated 4 years ago 11
Currently, when you insert a link from the Admin Setup Interface, you can just enter one text (as shown hereunder):

It would be very useful to add one more action button to enter translated texts for other languages, as available in other functionnalities of UserEcho.


We've added ability to translate links.
Satisfaction mark by Ryann 4 years ago
By the way,
  1. On the above snapshot, the text "Forum links" remains in English in any other language, whereas the translation exists for that string.
  2. In the next window opened from this point with the 3rd "Settings" icon:the text "New window" is not localized, but the translation seems not yet defined for the moment ;-)
1. It module instance name (like id for this module instance) that was created when module added. It shouldn't be translated.
2. Translated.
Another related point ;-)

  1. unlike the other setup window (first snapshot above), the blue action icons have no tooltip labels to "explain" the purpose of the buttons, whereas the grey action icons have tooltips. => Possible to add similar tooltips?
  2. the selected "world" icon leads currently to the above rotating wheel... that never ends... => A bug?
We've added ability to translate links.
Great news!
I just tried to translate already existing links (that were not translated):
I found the new icon button to "Translate", but no edition window opens after my click...
I've tried it on your website. It works fine. Please try refresh Ctrl+F5. If it doesn't help please write here will try to fix.
Unfortunately, I can't get it work:
after ctrl-F5, sign out, quit & relaunch browser (or even change browsers),
my click on the new "World" grey button to translate a link does not open an edit window for me.

Nevertheless, something "tries" to open since although I can't see anything on my screen, something blocks the vertical scrolling of the web page. Then I have to select another settings section (like "Custom Fields" for instance) to unblock the vertical scrolling...
Ryann, thanks for your description. We've fixed it.
Great! I confirm it works now.
Thanks a lot.